Hard to start and idle; Carbs or Petcock? - Page 3
Close
    
    
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 21 of 21
  1. #21
    Member
    Join Date
    Jul 2015
    Location
    Eastern WA
    Posts
    45
    I got my petcock today. I found two brass barbs, one with male and one with female threads on the opposite side and screwed them together with some yellow teflon tape; this allowed me to use the original hose to the new connector, and then the 1/4 hose to the new petcock. I ended up needing to reroute the fuel line so the line is a bit longer now, but it works great and fires up first time.
    Last edited by Solonys; 03-18-2017 at 10:51 PM. Reason: I fail at punctuation.
    1981 CX500C

Page 3 of 3 FirstFirst 1 2 3

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 12
    Last Post: 12-13-2016, 07:58 PM
  2. Petcock and Carbs Leaking, Bike Turns Over But No Start
    By HTX500 in forum Technical Help Forum
    Replies: 5
    Last Post: 04-19-2016, 02:26 PM
  3. 1978 CX500 hard to start after only 24 hours idle
    By leftparen in forum Technical Help Forum
    Replies: 15
    Last Post: 01-27-2015, 02:21 AM
  4. erratic idle.. hard start
    By outhere99 in forum Technical Help Forum
    Replies: 5
    Last Post: 05-07-2013, 10:27 AM
  5. Hard to start, wont idle, please help
    By Grifter_500 in forum Technical Help Forum
    Replies: 4
    Last Post: 04-29-2013, 07:23 PM