Turbo Technical Forum
Close
    
    
Threads 1 to 2 of 2

Forum: Turbo Technical Forum

Got a Turbo problem? Post it here and you'll get all the help you need!

  1. Cam shaft sensor (speed sensor) => broken magnet

    Started by johnste1960, 01-02-2017 06:05 PM
    2 Pages
    1 2
    broken magnet, johnste, magnet
    • Replies: 14
    • Views: 405
    01-08-2017, 05:54 PM Go to last post
  2. Question CX500 Turbo Suspension linkage

    Started by PGL, 09-13-2016 04:21 AM
    • Replies: 2
    • Views: 376
    PGL
    09-13-2016, 12:53 PM Go to last post

Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
More than 15 replies or 150 views
Hot thread with unread posts
More than 15 replies or 150 views
Hot thread with no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Current Poll

Which colour emblem do you prefer for your shirt?
White only
27.27%
The gray shown only
36.36%
A darker gray only
9.09%
I'll buy both gray and white
27.27%
Total Votes: 11
You may not vote on this poll.

» Sponsored Links

Powered by vBadvanced CMPS v4.3.0